summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc8xx/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc8xx/include/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc8xx/include/Makefile.am b/c/src/lib/libcpu/powerpc/mpc8xx/include/Makefile.am
new file mode 100644
index 0000000000..eb400375c0
--- /dev/null
+++ b/c/src/lib/libcpu/powerpc/mpc8xx/include/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = mpc8xx.h
+MPC8XX_H_FILES = console.h cpm.h mmu.h
+
+noinst_HEADERS = $(H_FILES) $(MPC8XX_H_FILES)
+
+PREINSTALL_FILES = \
+$(PROJECT_INCLUDE)/mpc8xx \
+$(H_FILES:%.h=$(PROJECT_INCLUDE)/%.h) \
+$(MPC8XX_H_FILES:%.h=$(PROJECT_INCLUDE)/mpc8xx/%.h)
+
+$(PROJECT_INCLUDE)/mpc8xx:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/mpc8xx/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am