summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am')
-rw-r--r--c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am b/c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am
new file mode 100644
index 0000000000..bdf83d0bc8
--- /dev/null
+++ b/c/src/lib/libcpu/m68k/m68040/fpsp/Makefile.am
@@ -0,0 +1,47 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = ${ARCH}/fpsp.rel
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../automake/lib.am
+
+# C source names, if any, go here -- minus the .c
+C_FILES = rtems_fpsp.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+H_FILES = fpsp.defs
+noinst_HEADERS = fpsp.defs
+
+# Assembly source names, if any, go here -- minus the .S
+S_FILES = bindec.S binstr.S bugfix.S decbin.S do_func.S gen_except.S \
+ get_op.S kernel_ex.S res_func.S round.S rtems_skel.S sacos.S sasin.S \
+ satan.S satanh.S scale.S scosh.S setox.S sgetem.S sint.S slog2.S slogn.S \
+ smovecr.S srem_mod.S ssin.S ssinh.S stan.S stanh.S sto_res.S stwotox.S \
+ tbldo.S util.S x_bsun.S x_fline.S x_operr.S x_ovfl.S x_snan.S x_store.S \
+ x_unfl.S x_unimp.S x_unsupp.S
+S_O_FILES = $(S_FILES:%.S=${ARCH}/%.o)
+
+OBJS = $(C_O_FILES) $(S_O_FILES)
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+AM_CFLAGS += $(CFLAGS_OS_V)
+
+$(PGM): ${OBJS}
+ $(make-rel)
+
+if m68040
+all-local: ${ARCH} $(PGM)
+else
+all-local:
+endif
+
+EXTRA_DIST = $(S_FILES) $(C_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am