summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/hppa1.1/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/hppa1.1/include/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/hppa1.1/include/Makefile.am b/c/src/lib/libcpu/hppa1.1/include/Makefile.am
new file mode 100644
index 0000000000..5d9a1326c9
--- /dev/null
+++ b/c/src/lib/libcpu/hppa1.1/include/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = runway.h semaphore.h
+noinst_HEADERS = $(H_FILES)
+
+# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
+# file name conflicts
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE)/hppa1.1 \
+$(H_FILES:%=$(PROJECT_INCLUDE)/hppa1.1/%)
+
+$(PROJECT_INCLUDE)/hppa1.1:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/hppa1.1/%.h: %.h
+ $(INSTALL_DATA) $@ $<
+
+all-local: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am