summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/a29k/timer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/a29k/timer/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/a29k/timer/Makefile.am b/c/src/lib/libcpu/a29k/timer/Makefile.am
new file mode 100644
index 0000000000..457e7fa2a6
--- /dev/null
+++ b/c/src/lib/libcpu/a29k/timer/Makefile.am
@@ -0,0 +1,36 @@
+##
+## Makefile,v 1.2 1995/05/31 16:56:37 joel Exp
+##
+## @(#)Makefile 03/26/96 1.2
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM=$(ARCH)/timer.rel
+
+# NOTE: timerisr is normally an assembly file!!!
+
+C_FILES = timer.c timerisr.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+S_FILES = gettime.S
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES) $(S_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(SRCS) $(OBJS)
+ $(make-rel)
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = Makefile gettime.S timer.c timerisr.c
+
+include $(top_srcdir)/../../../../../automake/local.am