summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/unix/posix/timer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/unix/posix/timer/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/c/src/lib/libbsp/unix/posix/timer/Makefile.am b/c/src/lib/libbsp/unix/posix/timer/Makefile.am
index 863c8be63f..96bc1e047b 100644
--- a/c/src/lib/libbsp/unix/posix/timer/Makefile.am
+++ b/c/src/lib/libbsp/unix/posix/timer/Makefile.am
@@ -4,11 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/timer.rel
+PGM = $(ARCH)/timer.rel
-## C source names
C_FILES = timer.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -21,12 +20,16 @@ include $(top_srcdir)/../../../../../../automake/lib.am
AM_CFLAGS = $(CFLAGS_OS_V)
-$(PGM): ${OBJS}
+$(PGM): $(OBJS)
$(make-rel)
-all-local: ${ARCH} $(PGM)
-
# the .rel file built here will be put into libbsp.a by
# ../wrapup/Makefile
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = timer.c
+
include $(top_srcdir)/../../../../../../automake/local.am