summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/unix/posix/clock/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/unix/posix/clock/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/unix/posix/clock/Makefile.am b/c/src/lib/libbsp/unix/posix/clock/Makefile.am
index 1ed273c1c4..8bb38a0a0a 100644
--- a/c/src/lib/libbsp/unix/posix/clock/Makefile.am
+++ b/c/src/lib/libbsp/unix/posix/clock/Makefile.am
@@ -4,11 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/clock.rel
+PGM = $(ARCH)/clock.rel
-## C source names
C_FILES = clock.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -19,14 +18,16 @@ include $(top_srcdir)/../../../../../../automake/lib.am
# (OPTIONAL) Add local stuff here using +=
#
-$(PGM): ${OBJS}
+$(PGM): $(OBJS)
$(make-rel)
-all-local: ${ARCH} $(PGM)
-
# the .rel file built here will be put into libbsp.a by
# ../wrapup/Makefile
-EXTRA_DIST = $(C_FILES)
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = clock.c
include $(top_srcdir)/../../../../../../automake/local.am