summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon3/shmsupp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon3/shmsupp/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon3/shmsupp/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/leon3/shmsupp/Makefile.am b/c/src/lib/libbsp/sparc/leon3/shmsupp/Makefile.am
new file mode 100644
index 0000000000..f2a6e08f02
--- /dev/null
+++ b/c/src/lib/libbsp/sparc/leon3/shmsupp/Makefile.am
@@ -0,0 +1,32 @@
+##
+## Makefile.am,v 1.4 2002/12/14 08:17:17 ralf Exp
+##
+
+
+PGM = $(ARCH)/shmsupp.rel
+
+C_FILES = addrconv.c getcfg.c lock.c mpisr.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+
+OBJS = $(C_O_FILES)
+
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+if HAS_MP
+all-local: $(ARCH) $(OBJS) $(PGM)
+endif
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = addrconv.c getcfg.c lock.c mpisr.c
+include $(top_srcdir)/../../../../../../automake/local.am