summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sparc/leon2/Makefile.am32
1 files changed, 3 insertions, 29 deletions
diff --git a/c/src/lib/libbsp/sparc/leon2/Makefile.am b/c/src/lib/libbsp/sparc/leon2/Makefile.am
index 1914c6956f..f7f2fd6937 100644
--- a/c/src/lib/libbsp/sparc/leon2/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon2/Makefile.am
@@ -169,29 +169,9 @@ libbsp_a_SOURCES += ../../shared/bspsmpgetcurrentprocessor.c
endif
if HAS_NETWORKING
-noinst_PROGRAMS += leon_smc91111.rel
-leon_smc91111_rel_SOURCES = leon_smc91111/leon_smc91111.c
-leon_smc91111_rel_CPPFLAGS = $(AM_CPPFLAGS)
-leon_smc91111_rel_CPPFLAGS += -D__INSIDE_RTEMS_BSD_TCPIP_STACK__
-leon_smc91111_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-endif
-
-if HAS_NETWORKING
-noinst_PROGRAMS += leon_open_eth.rel
-leon_open_eth_rel_SOURCES = leon_open_eth/leon_open_eth.c
-leon_open_eth_rel_CPPFLAGS = $(AM_CPPFLAGS)
-leon_open_eth_rel_CPPFLAGS += -D__INSIDE_RTEMS_BSD_TCPIP_STACK__
-leon_open_eth_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-endif
-
-if HAS_NETWORKING
-noinst_PROGRAMS += leon_greth.rel
-leon_greth_rel_SOURCES = ../../sparc/shared/net/greth.c
-leon_greth_rel_CPPFLAGS = $(AM_CPPFLAGS)
-leon_greth_rel_CPPFLAGS += -D__INSIDE_RTEMS_BSD_TCPIP_STACK__
-leon_greth_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-# BSP Network configuration
+libbsp_a_SOURCES += leon_smc91111/leon_smc91111.c
+libbsp_a_SOURCES += leon_open_eth/leon_open_eth.c
+libbsp_a_SOURCES += ../../sparc/shared/net/greth.c
libbsp_a_SOURCES += ../../sparc/shared/net/network_interface_add.c
endif
@@ -201,12 +181,6 @@ libbsp_a_LIBADD = \
../../../libcpu/@RTEMS_CPU@/reg_win.rel \
../../../libcpu/@RTEMS_CPU@/syscall.rel
-if HAS_NETWORKING
-libbsp_a_LIBADD += leon_greth.rel
-libbsp_a_LIBADD += leon_open_eth.rel
-libbsp_a_LIBADD += leon_smc91111.rel
-endif
-
EXTRA_DIST += times
include $(top_srcdir)/../../../../automake/local.am