summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon/configure.ac')
-rw-r--r--c/src/lib/libbsp/sparc/leon/configure.ac17
1 files changed, 15 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/sparc/leon/configure.ac b/c/src/lib/libbsp/sparc/leon/configure.ac
index 9b478017fe..d19333dcab 100644
--- a/c/src/lib/libbsp/sparc/leon/configure.ac
+++ b/c/src/lib/libbsp/sparc/leon/configure.ac
@@ -21,6 +21,21 @@ RTEMS_CHECK_NETWORKING
RTEMS_CONFIG_BUILD_SUBDIRS(tools)
+## bsp-specific options
+RTEMS_BSPOPTS_SET([CONSOLE_USE_INTERRUPTS],[*],[0])
+RTEMS_BSPOPTS_HELP([CONSOLE_USE_INTERRUPTS],
+[The erc32 console driver can operate in either polled or interrupt mode.
+Under the simulator (especially when FAST_UART is defined), polled seems to operate
+better. It is common for a task to print a line (like the end of test message) and
+then exit. In this case, the program returns control to the simulator command line
+before the program has even queued the output to the uart. Thus sis has no chance
+of getting the data out.])
+
+RTEMS_BSPOPTS_SET([SIMSPARC_FAST_IDLE],[*],[])
+RTEMS_BSPOPTS_HELP([SIMSPARC_FAST_IDLE],
+[If defined, speed up the clock ticks while the idle task is running so
+ time spent in the idle task is minimized. This significantly reduces
+ the wall time required to execute the RTEMS test suites.])
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
@@ -33,5 +48,3 @@ startup/Makefile
timer/Makefile
wrapup/Makefile])
AC_OUTPUT
-
-RTEMS_OUTPUT_BUILD_SUBDIRS(RTEMS_BUILD_SUBDIRS)