summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sparc/leon/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/sparc/leon/Makefile.am b/c/src/lib/libbsp/sparc/leon/Makefile.am
index 08a833f08e..b0159b6d68 100644
--- a/c/src/lib/libbsp/sparc/leon/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon/Makefile.am
@@ -5,13 +5,21 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . include start startup gnatsupp console clock timer \
- leon_open_eth wrapup tools
+# from the individual .rel files built in other directories
+SUBDIRS = . start startup gnatsupp console clock timer leon_open_eth wrapup \
+ tools
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs times
+include_HEADERS += include/leon.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = times
+
+$(PROJECT_INCLUDE)/leon.h: include/leon.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/leon.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am