summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sparc/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/Makefile.am b/c/src/lib/libbsp/sparc/Makefile.am
index c161d57d8e..3f2bfff9a4 100644
--- a/c/src/lib/libbsp/sparc/Makefile.am
+++ b/c/src/lib/libbsp/sparc/Makefile.am
@@ -18,5 +18,46 @@ EXTRA_DIST += shared/start.S
EXTRA_DIST += shared/include/ambapp.h
EXTRA_DIST += shared/amba/ambapp.c
+# PCI bus
+EXTRA_DIST += shared/include/pci.h
+EXTRA_DIST += shared/pci/pcifinddevice.c
+
+# DEBUG
+EXTRA_DIST += shared/include/debug_defs.h
+
+# SpaceWire (GRSPW)
+EXTRA_DIST += shared/spw/grspw.c
+EXTRA_DIST += shared/spw/grspw_pci.c
+EXTRA_DIST += shared/spw/grspw_rasta.c
+EXTRA_DIST += shared/include/grspw.h
+EXTRA_DIST += shared/include/grspw_pci.h
+EXTRA_DIST += shared/include/grspw_rasta.h
+
+# UART (APBUART)
+EXTRA_DIST += shared/uart/apbuart.c
+EXTRA_DIST += shared/uart/apbuart_pci.c
+EXTRA_DIST += shared/uart/apbuart_rasta.c
+EXTRA_DIST += shared/include/apbuart.h
+EXTRA_DIST += shared/include/apbuart_pci.h
+EXTRA_DIST += shared/include/apbuart_rasta.h
+
+# CAN (OC_CAN, GRCAN)
+EXTRA_DIST += shared/can/occan.c
+EXTRA_DIST += shared/can/occan_pci.c
+EXTRA_DIST += shared/can/grcan.c
+EXTRA_DIST += shared/can/grcan_rasta.c
+EXTRA_DIST += shared/include/occan.h
+EXTRA_DIST += shared/include/occan_pci.h
+EXTRA_DIST += shared/include/grcan.h
+EXTRA_DIST += shared/include/grcan_rasta.h
+
+# MIL-STD-B1553 (Core1553BRM)
+EXTRA_DIST += shared/1553/b1553brm.c
+EXTRA_DIST += shared/1553/b1553brm_pci.c
+EXTRA_DIST += shared/1553/b1553brm_rasta.c
+EXTRA_DIST += shared/include/b1553brm.h
+EXTRA_DIST += shared/include/b1553brm_pci.h
+EXTRA_DIST += shared/include/b1553brm_rasta.h
+
include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am