summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/console/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/simsh4/console/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/console/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/console/Makefile.am b/c/src/lib/libbsp/sh/simsh4/console/Makefile.am
new file mode 100644
index 0000000000..d759853180
--- /dev/null
+++ b/c/src/lib/libbsp/sh/simsh4/console/Makefile.am
@@ -0,0 +1,34 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@
+
+PGM = $(ARCH)/console.rel
+
+C_FILES = console.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+# the .rel file built here will be put into libbsp.a by
+# ../wrapup/Makefile
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+include $(top_srcdir)/../../../../../../automake/local.am