summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/simsh4/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/Makefile.am b/c/src/lib/libbsp/sh/simsh4/Makefile.am
index be2ed68e98..b1ceba252c 100644
--- a/c/src/lib/libbsp/sh/simsh4/Makefile.am
+++ b/c/src/lib/libbsp/sh/simsh4/Makefile.am
@@ -35,6 +35,8 @@ project_lib_DATA = start.$(OBJEXT)
dist_project_lib_DATA += startup/linkcmds startup/linkcmds-le \
startup/linkcmds-le.coff
+noinst_LIBRARIES = libbsp.a
+
startup_SOURCES = startup/hw_init.c ../../shared/bsplibc.c \
../../shared/bsppost.c ../../shared/bsppredriverhook.c \
../../shared/bsppretaskinghook.c ../../shared/bspgetworkarea.c \
@@ -45,7 +47,6 @@ clock_SOURCES = clock/ckinit.c
console_SOURCES = console/console.c ../../shared/dummy_printk_support.c
timer_SOURCES = timer/timer.c
-noinst_LIBRARIES = libbsp.a
libbsp_a_SOURCES = $(startup_SOURCES) $(clock_SOURCES) $(console_SOURCES) \
$(timer_SOURCES)