summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/shsim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/shsim/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/Makefile.am b/c/src/lib/libbsp/sh/shsim/Makefile.am
index 19a75d57a2..5fbc89b603 100644
--- a/c/src/lib/libbsp/sh/shsim/Makefile.am
+++ b/c/src/lib/libbsp/sh/shsim/Makefile.am
@@ -5,12 +5,23 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = include start startup clock scitab gdbsci console wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . start startup clock scitab gdbsci console wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs
+include_HEADERS += include/gdbsci.h
+nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+$(PROJECT_INCLUDE)/gdbsci.h: include/gdbsci.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/gdbsci.h
+
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am