summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh4/hw_init/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/gensh4/hw_init/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/gensh4/hw_init/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/gensh4/hw_init/Makefile.am b/c/src/lib/libbsp/sh/gensh4/hw_init/Makefile.am
new file mode 100644
index 0000000000..81fdc58949
--- /dev/null
+++ b/c/src/lib/libbsp/sh/gensh4/hw_init/Makefile.am
@@ -0,0 +1,39 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/../../shared:@srcdir@/../../../shared
+
+PGM = $(ARCH)/hw_init.rel
+
+#C_FILES = hw_init.c bsplibc.c bsppost.c bspstart.c bspclean.c sbrk.c \
+# bootcard.c main.c gnatinstallhandler.c
+C_FILES = hw_init.c
+
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+AM_CPPFLAGS += -DHZ=$(HZ)
+AM_CFLAGS += -fomit-frame-pointer
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = hw_init.c
+
+include $(top_srcdir)/../../../../../../automake/local.am