summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am b/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
new file mode 100644
index 0000000000..729473ac56
--- /dev/null
+++ b/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
@@ -0,0 +1,36 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/scitab.rel
+
+## C source names
+C_FILES = scitab.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+SHGEN = $(PROJECT_ROOT)/tools/cpu/sh/shgen
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): ${OBJS}
+ $(make-rel)
+
+all-local: ${ARCH} $(PGM)
+
+scitab.c: $(SHGEN)
+ $(SHGEN) -H $(HZ) sci > $@
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+EXTRA_DIST = $(C_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am