summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh1/scitab/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/gensh1/scitab/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/sh/gensh1/scitab/Makefile.am b/c/src/lib/libbsp/sh/gensh1/scitab/Makefile.am
index 563f4cef46..b885f76b71 100644
--- a/c/src/lib/libbsp/sh/gensh1/scitab/Makefile.am
+++ b/c/src/lib/libbsp/sh/gensh1/scitab/Makefile.am
@@ -6,9 +6,8 @@ AUTOMAKE_OPTIONS = foreign 1.4
PGM = $(ARCH)/scitab.rel
-## C source names
C_FILES = scitab.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -23,12 +22,14 @@ SHGEN = $(PROJECT_ROOT)/tools/cpu/sh/shgen
CLEANFILES = scitab.c
-$(PGM): ${OBJS}
+$(PGM): $(OBJS)
$(make-rel)
-all-local: ${ARCH} $(PGM)
-
scitab.c: $(SHGEN)
$(SHGEN) -H $(HZ) sci > $@
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
include $(top_srcdir)/../../../../../../automake/local.am