summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh1/console/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/gensh1/console/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/gensh1/console/Makefile.am b/c/src/lib/libbsp/sh/gensh1/console/Makefile.am
new file mode 100644
index 0000000000..ef2d64c4be
--- /dev/null
+++ b/c/src/lib/libbsp/sh/gensh1/console/Makefile.am
@@ -0,0 +1,32 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/../../shared
+
+PGM = ${ARCH}/console.rel
+
+## C source names
+C_FILES = console.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): ${OBJS}
+ $(make-rel)
+
+all-local: ${ARCH} $(PGM)
+
+# the .rel file built here will be put into libbsp.a by
+# ../wrapup/Makefile
+
+include $(top_srcdir)/../../../../../../automake/local.am