summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/tqm8xx/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/tqm8xx/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/tqm8xx/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/tqm8xx/configure.ac b/c/src/lib/libbsp/powerpc/tqm8xx/configure.ac
index a72893cffc..46cc402200 100644
--- a/c/src/lib/libbsp/powerpc/tqm8xx/configure.ac
+++ b/c/src/lib/libbsp/powerpc/tqm8xx/configure.ac
@@ -18,6 +18,10 @@ RTEMS_PROG_CCAS
RTEMS_CHECK_NETWORKING
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+## This is needed to generate the field offsets of the per CPU
+## data structure so they can be accessed from assembly code.
+AC_CHECK_SIZEOF([void *])
+
RTEMS_BSPOPTS_SET([PPC_USE_DATA_CACHE],[*],[1])
RTEMS_BSPOPTS_HELP([PPC_USE_DATA_CACHE],
[If defined, then the PowerPC specific code in RTEMS will use