summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am29
1 files changed, 13 insertions, 16 deletions
diff --git a/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am b/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
index d484bc0fbe..0f31ca677a 100644
--- a/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
@@ -2,28 +2,33 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
+
+ACLOCAL_AMFLAGS = -I ../../../../../../../aclocal
C_FILES = cpu.c
C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
include_rtems_scoredir = $(includedir)/rtems/score
-include_rtems_score_HEADERS = cpu.h c_isr.inl
+include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/c_isr.inl
S_FILES = cpu_asm.S
S_O_FILES = $(S_FILES:%.S=${ARCH}/%.o)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../../../automake/compile.am
-include $(top_srcdir)/../../../../../automake/lib.am
+include $(top_srcdir)/../../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../../automake/lib.am
#
# (OPTIONAL) Add local stuff here using +=
#
-PREINSTALL_FILES = $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/rtems/score \
- $(include_rtems_score_HEADERS:%=$(PROJECT_INCLUDE)/rtems/score/%)
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/rtems/score \
+ $(include_rtems_score_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+# FIXME: This should not be here.
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/score/cpu.h
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
@@ -31,24 +36,16 @@ $(PROJECT_INCLUDE):
$(PROJECT_INCLUDE)/rtems/score:
$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/rtems/score/%: %
- $(INSTALL_DATA) $< $@
-
$(PROJECT_INCLUDE)/%: %
$(INSTALL_DATA) $< $@
REL = $(ARCH)/rtems-cpu.rel
$(REL): $(C_O_FILES) $(S_O_FILES)
- test -d ../$(ARCH) || mkdir ../$(ARCH)
$(make-rel)
-all-local: $(ARCH) $(PREINSTALL_FILES) $(REL)
-## all-local: $(ARCH)/rtems.o
-all-local: $(TMPINSTALL_FILES)
-
-CLEANDIRS = ../o-optimize ../o-debug ../o-profile
+all-local: $(ARCH) $(TMPINSTALL_FILES) $(REL)
EXTRA_DIST = $(C_FILES) $(S_FILES)
-include $(top_srcdir)/../../../../../automake/local.am
+include $(top_srcdir)/../../../../../../../automake/local.am