summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/ss555/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/ss555/wrapup/Makefile.am31
1 files changed, 11 insertions, 20 deletions
diff --git a/c/src/lib/libbsp/powerpc/ss555/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/ss555/wrapup/Makefile.am
index 845d14cf54..73059f55b2 100644
--- a/c/src/lib/libbsp/powerpc/ss555/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/ss555/wrapup/Makefile.am
@@ -4,29 +4,20 @@
include $(top_srcdir)/../../../../automake/compile.am
-EXTRA_LIBRARIES = ../libbsp.a
+noinst_LIBRARIES = ../libbsp.a
CLEANFILES = ../libbsp.a
___libbsp_a_SOURCES =
-___libbsp_a_LIBADD = ../pclock$(LIB_VARIANT).rel \
- ../console$(LIB_VARIANT).rel ../startup$(LIB_VARIANT).rel \
- ../tm27supp$(LIB_VARIANT).rel
+___libbsp_a_LIBADD = ../pclock.rel ../console.rel ../startup.rel \
+ ../tm27supp.rel
-___libbsp_a_LIBADD += \
- ../../../../libcpu/powerpc/shared/cpuIdent$(LIB_VARIANT).rel \
- ../@exceptions@/rtems-cpu$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc5xx/clock$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc5xx/console-generic$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc5xx/exceptions$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc5xx/irq$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc5xx/timer$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc5xx/vectors$(LIB_VARIANT).rel
-
-EXTRA_LIBRARIES += ../libbsp_g.a
-CLEANFILES += ../libbsp_g.a
-___libbsp_g_a_SOURCES = $(___libbsp_a_SOURCES)
-___libbsp_g_a_LIBADD = $(___libbsp_a_LIBADD)
-
-noinst_DATA = ../libbsp$(LIB_VARIANT).a
+___libbsp_a_LIBADD += ../../../../libcpu/powerpc/shared/cpuIdent.rel \
+ ../@exceptions@/rtems-cpu.rel \
+ ../../../../libcpu/powerpc/mpc5xx/clock.rel \
+ ../../../../libcpu/powerpc/mpc5xx/console-generic.rel \
+ ../../../../libcpu/powerpc/mpc5xx/exceptions.rel \
+ ../../../../libcpu/powerpc/mpc5xx/irq.rel \
+ ../../../../libcpu/powerpc/mpc5xx/timer.rel \
+ ../../../../libcpu/powerpc/mpc5xx/vectors.rel
include $(top_srcdir)/../../../../automake/local.am