summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/ppcn_60x/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/ppcn_60x/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/ppcn_60x/configure.ac50
1 files changed, 50 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/ppcn_60x/configure.ac b/c/src/lib/libbsp/powerpc/ppcn_60x/configure.ac
new file mode 100644
index 0000000000..1c32eaabd3
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/ppcn_60x/configure.ac
@@ -0,0 +1,50 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libbsp-powerpc-ppcn_60x,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+RTEMS_CHECK_NETWORKING
+RTEMS_CANONICAL_HOST
+
+# Don't build the network directory
+# The problem is that the code there has not yet been converted to
+# bsd networking
+AM_CONDITIONAL(HAS_NETWORKING,false)
+# AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+
+
+RTEMS_PROJECT_ROOT
+AM_CONFIG_HEADER(include/bspopts.h)
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+clock/Makefile
+console/Makefile
+include/Makefile
+network/Makefile
+nvram/Makefile
+pci/Makefile
+start/Makefile
+startup/Makefile
+timer/Makefile
+tod/Makefile
+universe/Makefile
+vectors/Makefile
+wrapup/Makefile])
+AC_OUTPUT
+