summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/papyrus/dlentry/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/papyrus/dlentry/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/papyrus/dlentry/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/papyrus/dlentry/Makefile.am b/c/src/lib/libbsp/powerpc/papyrus/dlentry/Makefile.am
new file mode 100644
index 0000000000..70c08c79f7
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/papyrus/dlentry/Makefile.am
@@ -0,0 +1,32 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/dlentry.rel
+
+S_FILES = dlentry.S
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+
+OBJS = $(S_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = dlentry.S
+
+include $(top_srcdir)/../../../../../../automake/local.am