summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am35
1 files changed, 13 insertions, 22 deletions
diff --git a/c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am
index 7cab8f42a8..3036e28e4a 100644
--- a/c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am
@@ -4,31 +4,22 @@
include $(top_srcdir)/../../../../automake/compile.am
-EXTRA_LIBRARIES = ../libbsp.a
+noinst_LIBRARIES = ../libbsp.a
CLEANFILES = ../libbsp.a
___libbsp_a_SOURCES =
-___libbsp_a_LIBADD = ../pclock$(LIB_VARIANT).rel ../irq$(LIB_VARIANT).rel \
- ../startup$(LIB_VARIANT).rel ../console$(LIB_VARIANT).rel \
- ../vectors$(LIB_VARIANT).rel
+___libbsp_a_LIBADD = ../pclock.rel ../irq.rel ../startup.rel ../console.rel \
+ ../vectors.rel
if HAS_NETWORKING
-___libbsp_a_LIBADD += ../network$(LIB_VARIANT).rel
+___libbsp_a_LIBADD += ../network.rel
endif
-___libbsp_a_LIBADD += \
- ../../../../libcpu/powerpc/shared/cpuIdent$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/shared/cache$(LIB_VARIANT).rel \
- ../@exceptions@/rtems-cpu$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc8260/clock$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc8260/console-generic$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc8260/cpm$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc8260/mmu$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc8260/timer$(LIB_VARIANT).rel \
- ../../../../libcpu/powerpc/mpc8260/exceptions$(LIB_VARIANT).rel
-
-EXTRA_LIBRARIES += ../libbsp_g.a
-CLEANFILES += ../libbsp_g.a
-___libbsp_g_a_SOURCES = $(___libbsp_a_SOURCES)
-___libbsp_g_a_LIBADD = $(___libbsp_a_LIBADD)
-
-noinst_DATA = ../libbsp$(LIB_VARIANT).a
+___libbsp_a_LIBADD += ../../../../libcpu/powerpc/shared/cpuIdent.rel \
+ ../../../../libcpu/powerpc/shared/cache.rel \
+ ../@exceptions@/rtems-cpu.rel \
+ ../../../../libcpu/powerpc/mpc8260/clock.rel \
+ ../../../../libcpu/powerpc/mpc8260/console-generic.rel \
+ ../../../../libcpu/powerpc/mpc8260/cpm.rel \
+ ../../../../libcpu/powerpc/mpc8260/mmu.rel \
+ ../../../../libcpu/powerpc/mpc8260/timer.rel \
+ ../../../../libcpu/powerpc/mpc8260/exceptions.rel
include $(top_srcdir)/../../../../automake/local.am