summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mpc8260ads/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/mpc8260ads/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/powerpc/mpc8260ads/Makefile.am b/c/src/lib/libbsp/powerpc/mpc8260ads/Makefile.am
index 018e5e6925..8cf012b6da 100644
--- a/c/src/lib/libbsp/powerpc/mpc8260ads/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mpc8260ads/Makefile.am
@@ -4,10 +4,6 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
-# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . @exceptions@ wrapup
-
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../bsp.am
@@ -73,6 +69,22 @@ network_rel_CPPFLAGS = $(AM_CPPFLAGS) $(network_CPPFLAGS)
network_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
+noinst_LIBRARIES = libbsp.a
+libbsp_a_SOURCES =
+libbsp_a_LIBADD = pclock.rel irq.rel startup.rel console.rel vectors.rel
+if HAS_NETWORKING
+libbsp_a_LIBADD += network.rel
+endif
+libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/shared/cpuIdent.rel \
+ ../../../libcpu/@RTEMS_CPU@/shared/cache.rel \
+ ../../../libcpu/@RTEMS_CPU@/@exceptions@/rtems-cpu.rel \
+ ../../../libcpu/@RTEMS_CPU@/mpc8260/clock.rel \
+ ../../../libcpu/@RTEMS_CPU@/mpc8260/console-generic.rel \
+ ../../../libcpu/@RTEMS_CPU@/mpc8260/cpm.rel \
+ ../../../libcpu/@RTEMS_CPU@/mpc8260/mmu.rel \
+ ../../../libcpu/@RTEMS_CPU@/mpc8260/timer.rel \
+ ../../../libcpu/@RTEMS_CPU@/mpc8260/exceptions.rel
+
all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST += times