summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/helas403/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/powerpc/helas403/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/helas403/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/helas403/configure.ac b/c/src/lib/libbsp/powerpc/helas403/configure.ac
index 14fca817df..c8174178ea 100644
--- a/c/src/lib/libbsp/powerpc/helas403/configure.ac
+++ b/c/src/lib/libbsp/powerpc/helas403/configure.ac
@@ -24,6 +24,18 @@ RTEMS_CANONICAL_HOST
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+RTEMS_BSPOPTS_SET([PPC_USE_SPRG],[*],[1])
+RTEMS_BSPOPTS_HELP([PPC_USE_SPRG],
+[If defined, then the PowerPC specific code in RTEMS will use some
+of the special purpose registers to slightly optimize interrupt
+response time. The use of these registers can conflict with
+other tools like debuggers.])
+
+RTEMS_BSPOPTS_SET([PPC_VECTOR_FILE_BASE],[*],[0x0100])
+RTEMS_BSPOPTS_HELP([PPC_VECTOR_FILE_BASE],
+[This defines the base address of the exception table.
+ NOTE: Vectors are actually at 0xFFF00000 but file starts at offset.])
+
AM_CONFIG_HEADER(include/bspopts.h)
RTEMS_PROJECT_ROOT
@@ -34,4 +46,7 @@ flashentry/Makefile
include/Makefile
startup/Makefile
wrapup/Makefile])
+
+RTEMS_PPC_EXCEPTIONS([old])
+
AC_OUTPUT