summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/helas403/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/helas403/Makefile.am43
1 files changed, 8 insertions, 35 deletions
diff --git a/c/src/lib/libbsp/powerpc/helas403/Makefile.am b/c/src/lib/libbsp/powerpc/helas403/Makefile.am
index 73757752ad..0ea91ff647 100644
--- a/c/src/lib/libbsp/powerpc/helas403/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/helas403/Makefile.am
@@ -15,48 +15,29 @@ dist_project_lib_DATA = bsp_specs
include_HEADERS = include/bsp.h
include_HEADERS += include/tm27.h
+
nodist_include_HEADERS = include/bspopts.h
+DISTCLEANFILES = include/bspopts.h
-EXTRA_PROGRAMS =
-CLEANFILES =
-noinst_DATA =
+noinst_PROGRAMS =
dist_project_lib_DATA += bsp_specs.dl
include_HEADERS += include/coverhd.h
-EXTRA_PROGRAMS += dlentry.rel
-CLEANFILES += dlentry.rel
+noinst_PROGRAMS += dlentry.rel
dlentry_rel_SOURCES = dlentry/dlentry.S
dlentry_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
dlentry_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += dlentry_g.rel
-CLEANFILES += dlentry_g.rel
-dlentry_g_rel_SOURCES = $(dlentry_rel_SOURCES)
-dlentry_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-dlentry_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += dlentry$(LIB_VARIANT).rel
-
-EXTRA_PROGRAMS += flashentry.rel
-CLEANFILES += flashentry.rel
+noinst_PROGRAMS += flashentry.rel
flashentry_rel_SOURCES = flashentry/flashentry.S
flashentry_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
flashentry_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += flashentry_g.rel
-CLEANFILES += flashentry_g.rel
-flashentry_g_rel_SOURCES = $(flashentry_rel_SOURCES)
-flashentry_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-flashentry_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += flashentry$(LIB_VARIANT).rel
-
dist_project_lib_DATA += startup/linkcmds startup/linkcmds.dl
-EXTRA_PROGRAMS += startup.rel
-CLEANFILES += startup.rel
+noinst_PROGRAMS += startup.rel
startup_rel_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
../../shared/bsppost.c startup/bspstart.c ../../shared/bootcard.c \
../../shared/main.c ../../shared/sbrk.c startup/setvec.c \
@@ -64,14 +45,6 @@ startup_rel_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
startup_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
startup_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += startup_g.rel
-CLEANFILES += startup_g.rel
-startup_g_rel_SOURCES = $(startup_rel_SOURCES)
-startup_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-startup_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += startup$(LIB_VARIANT).rel
-
all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST = times
@@ -121,8 +94,8 @@ $(PROJECT_LIB)/linkcmds.dl: startup/linkcmds.dl $(PROJECT_LIB)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds.dl
PREINSTALL_FILES += $(PROJECT_LIB)/linkcmds.dl
-CLEANFILES += $(PREINSTALL_FILES)
-DISTCLEANFILES = $(PREINSTALL_DIRS)
+CLEANFILES = $(PREINSTALL_FILES)
+DISTCLEANFILES += $(PREINSTALL_DIRS)
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am