summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen5200/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/gen5200/Makefile.am61
1 files changed, 9 insertions, 52 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen5200/Makefile.am b/c/src/lib/libbsp/powerpc/gen5200/Makefile.am
index 88e8d5191b..a727020c0a 100644
--- a/c/src/lib/libbsp/powerpc/gen5200/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/gen5200/Makefile.am
@@ -4,18 +4,8 @@ EXTRA_DIST =
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../bsp.am
-include_bspdir = $(includedir)/bsp
-include_bestcommdir = $(include_bspdir)/bestcomm
-include_bestcomm_includedir = $(include_bestcommdir)/include
-include_bestcomm_include_mgt5200dir = $(include_bestcomm_includedir)/mgt5200
-include_bestcomm_task_apidir = $(include_bestcommdir)/task_api
+dist_project_lib_DATA = startup/bsp_specs
-dist_project_lib_DATA = bsp_specs
-
-include_HEADERS = include/bsp.h
-include_HEADERS += include/tm27.h
-
-nodist_include_HEADERS = include/bspopts.h
DISTCLEANFILES = include/bspopts.h
noinst_PROGRAMS =
@@ -31,14 +21,14 @@ rtems_crti.$(OBJEXT): ../../powerpc/shared/start/rtems_crti.S
$(CPPASCOMPILE) -o $@ -c $<
project_lib_DATA += rtems_crti.$(OBJEXT)
+project_lib_DATA += linkcmds
+dist_project_lib_DATA += startup/linkcmds.brs5l
+dist_project_lib_DATA += startup/linkcmds.brs6l
+dist_project_lib_DATA += startup/linkcmds.dp2
dist_project_lib_DATA += startup/linkcmds.gen5200_base
-project_lib_DATA += startup/linkcmds
-EXTRA_DIST += startup/linkcmds.brs5l
-EXTRA_DIST += startup/linkcmds.brs6l
-EXTRA_DIST += startup/linkcmds.icecube
-EXTRA_DIST += startup/linkcmds.pm520_cr825
-EXTRA_DIST += startup/linkcmds.pm520_ze30
-EXTRA_DIST += startup/linkcmds.dp2
+dist_project_lib_DATA += startup/linkcmds.icecube
+dist_project_lib_DATA += startup/linkcmds.pm520_cr825
+dist_project_lib_DATA += startup/linkcmds.pm520_ze30
noinst_LIBRARIES = libbsp.a
libbsp_a_SOURCES =
@@ -61,19 +51,6 @@ libbsp_a_SOURCES += bestcomm/include/ppctypes.h \
bestcomm/task_api/bestcomm_api_mem.h bestcomm/task_api/bestcomm_cntrl.h \
bestcomm/task_api/tasksetup_bdtable.h \
bestcomm/task_api/tasksetup_general.h
-include_bestcomm_HEADERS = bestcomm/bestcomm_priv.h \
- bestcomm/dma_image.h \
- bestcomm/dma_image.capi.h \
- bestcomm/bestcomm_api.h \
- bestcomm/bestcomm_glue.h
-include_bestcomm_include_HEADERS = bestcomm/include/ppctypes.h
-include_bestcomm_include_mgt5200_HEADERS = bestcomm/include/mgt5200/mgt5200.h \
- bestcomm/include/mgt5200/sdma.h
-include_bestcomm_task_api_HEADERS = bestcomm/task_api/tasksetup_general.h \
- bestcomm/task_api/tasksetup_bdtable.h \
- bestcomm/task_api/bestcomm_cntrl.h \
- bestcomm/task_api/bestcomm_api_mem.h
-
# clock
# clock
libbsp_a_SOURCES += ../shared/clock/clock.c
@@ -87,24 +64,6 @@ libbsp_a_SOURCES += ide/ata.c
libbsp_a_SOURCES += ide/ata-instance.c
libbsp_a_SOURCES += ide/ata-dma-pio-single.c
-include_bsp_HEADERS =
-include_bsp_HEADERS += ../../shared/include/bootcard.h
-include_bsp_HEADERS += ../../shared/include/irq-generic.h
-include_bsp_HEADERS += ../../shared/include/irq-info.h
-include_bsp_HEADERS += ../../shared/include/u-boot.h
-include_bsp_HEADERS += ../../shared/include/utility.h
-include_bsp_HEADERS += ../shared/include/u-boot-board-info.h
-include_bsp_HEADERS += include/ata.h
-include_bsp_HEADERS += include/bestcomm.h
-include_bsp_HEADERS += include/bestcomm_ops.h
-include_bsp_HEADERS += include/i2cdrv.h
-include_bsp_HEADERS += include/i2c.h
-include_bsp_HEADERS += include/irq.h
-include_bsp_HEADERS += include/mpc5200.h
-include_bsp_HEADERS += include/mscan-base.h
-include_bsp_HEADERS += include/u-boot-config.h
-include_bsp_HEADERS += mscan/mscan.h
-
# irq
libbsp_a_SOURCES += include/irq.h \
irq/irq.c \
@@ -117,11 +76,9 @@ libbsp_a_SOURCES += include/irq.h \
# mscan
libbsp_a_SOURCES += mscan/mscan.c mscan/mscan-base.c mscan/mscan.h mscan/mscan_int.h
-include_bsp_HEADERS += nvram/nvram.h
# nvram
libbsp_a_SOURCES += nvram/nvram.c nvram/nvram.h nvram/m93cxx.h
-include_bsp_HEADERS += slicetimer/slicetimer.h
# slicetimer
libbsp_a_SOURCES += slicetimer/slicetimer.c slicetimer/slicetimer.h
@@ -161,5 +118,5 @@ libbsp_a_LIBADD = ../../../libcpu/@RTEMS_CPU@/shared/cpuIdent.rel \
../../../libcpu/@RTEMS_CPU@/mpc6xx/mmu.rel \
../../../libcpu/@RTEMS_CPU@/mpc6xx/timer.rel
-include $(srcdir)/preinstall.am
include $(top_srcdir)/../../../../automake/local.am
+include $(srcdir)/../../../../../../bsps/powerpc/gen5200/headers.am