summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am
index 4e970ba624..72b67b0d68 100644
--- a/c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am
@@ -4,12 +4,16 @@
BSP_PIECES = startup dlentry
# pieces to pick up out of libcpu/ppc
-CPU_PIECES = clock timer console tty_drv vectors ictrl
# bummer; have to use $foreach since % pattern subst rules only replace 1x
OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- ../@exceptions@/$(ARCH)/rtems-cpu.rel $(foreach piece, $(CPU_PIECES), \
- ../../../../libcpu/$(RTEMS_CPU)/ppc403/$(piece)/$(ARCH)/$(piece).rel)
+ ../@exceptions@/$(ARCH)/rtems-cpu.rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/clock$(LIB_VARIANT).rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/timer$(LIB_VARIANT).rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/console$(LIB_VARIANT).rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/tty_drv$(LIB_VARIANT).rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/vectors$(LIB_VARIANT).rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/ictrl$(LIB_VARIANT).rel
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am