summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen405/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/gen405/Makefile.am32
1 files changed, 7 insertions, 25 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen405/Makefile.am b/c/src/lib/libbsp/powerpc/gen405/Makefile.am
index 63ef93b43c..8a74ae0405 100644
--- a/c/src/lib/libbsp/powerpc/gen405/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/gen405/Makefile.am
@@ -15,18 +15,17 @@ dist_project_lib_DATA = bsp_specs
include_HEADERS = include/bsp.h
include_HEADERS += include/tm27.h
+
nodist_include_HEADERS = include/bspopts.h
+DISTCLEANFILES = include/bspopts.h
-EXTRA_PROGRAMS =
-CLEANFILES =
-noinst_DATA =
+noinst_PROGRAMS =
include_HEADERS += include/coverhd.h
dist_project_lib_DATA += startup/linkcmds startup/linkcmds.dl
-EXTRA_PROGRAMS += startup.rel
-CLEANFILES += startup.rel
+noinst_PROGRAMS += startup.rel
startup_rel_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
../../shared/bsppost.c startup/bspstart.c ../../shared/bootcard.c \
../../shared/main.c ../../shared/sbrk.c startup/setvec.c \
@@ -34,28 +33,11 @@ startup_rel_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
startup_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
startup_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += startup_g.rel
-CLEANFILES += startup_g.rel
-startup_g_rel_SOURCES = $(startup_rel_SOURCES)
-startup_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-startup_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += startup$(LIB_VARIANT).rel
-
-EXTRA_PROGRAMS += dlentry.rel
-CLEANFILES += dlentry.rel
+noinst_PROGRAMS += dlentry.rel
dlentry_rel_SOURCES = dlentry/dlentry.S
dlentry_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
dlentry_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += dlentry_g.rel
-CLEANFILES += dlentry_g.rel
-dlentry_g_rel_SOURCES = $(dlentry_rel_SOURCES)
-dlentry_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-dlentry_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += dlentry$(LIB_VARIANT).rel
-
all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST = times
@@ -101,8 +83,8 @@ $(PROJECT_LIB)/linkcmds.dl: startup/linkcmds.dl $(PROJECT_LIB)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds.dl
PREINSTALL_FILES += $(PROJECT_LIB)/linkcmds.dl
-CLEANFILES += $(PREINSTALL_FILES)
-DISTCLEANFILES = $(PREINSTALL_DIRS)
+CLEANFILES = $(PREINSTALL_FILES)
+DISTCLEANFILES += $(PREINSTALL_DIRS)
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am