summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/eth_comm/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/eth_comm/include/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/eth_comm/include/Makefile.am b/c/src/lib/libbsp/powerpc/eth_comm/include/Makefile.am
new file mode 100644
index 0000000000..680492e1b7
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/eth_comm/include/Makefile.am
@@ -0,0 +1,32 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = bsp.h coverhd.h canbus.h info.h
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/bsp.h: bsp.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/coverhd.h: coverhd.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/canbus.h: canbus.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/info.h: info.h
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/bsp.h \
+ $(PROJECT_INCLUDE)/coverhd.h $(PROJECT_INCLUDE)/canbus.h \
+ $(PROJECT_INCLUDE)/info.h
+
+all-local: $(TMPINSTALL_FILES)
+
+EXTRA_DIST = bsp.h canbus.h coverhd.h info.h
+
+include $(top_srcdir)/../../../../../../automake/local.am