summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/dmv177/configure.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/dmv177/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/dmv177/configure.in b/c/src/lib/libbsp/powerpc/dmv177/configure.in
index 7e98c7038f..ec37042556 100644
--- a/c/src/lib/libbsp/powerpc/dmv177/configure.in
+++ b/c/src/lib/libbsp/powerpc/dmv177/configure.in
@@ -23,6 +23,25 @@ RTEMS_CANONICAL_HOST
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+## bsp-specific options
+CONSOLE_USE_INTERRUPTS=${CONSOLE_USE_INTERRUPTS-0}
+AC_DEFINE_UNQUOTED([CONSOLE_USE_INTERRUPTS],
+ [$CONSOLE_USE_INTERRUPTS],
+ [whether using console interrupts])
+
+## FIXME: this is redundant to CONSOLE_USE_INTERRUPTS
+CONSOLE_USE_POLLED="!CONSOLE_USE_INTERRUPTS"
+AC_DEFINE_UNQUOTED([CONSOLE_USE_POLLED],
+ [$CONSOLE_USE_POLLED],
+ [whether using polled console])
+
+## FIXME: This is not used anywhere
+HAS_RTC=${HAS_RTC-yes}
+AC_DEFINE_UNQUOTED([HAS_RTC],
+ [$HAS_RTC],
+ [whether this BSP has an RTC])
+
+AM_CONFIG_HEADER(include/bspopts.h)
RTEMS_PROJECT_ROOT
# Explicitly list all Makefiles here