summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/or1k/or1ksim/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/or1k/or1ksim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/or1k/or1ksim/Makefile.am110
1 files changed, 0 insertions, 110 deletions
diff --git a/c/src/lib/libbsp/or1k/or1ksim/Makefile.am b/c/src/lib/libbsp/or1k/or1ksim/Makefile.am
deleted file mode 100644
index 7a871b511e..0000000000
--- a/c/src/lib/libbsp/or1k/or1ksim/Makefile.am
+++ /dev/null
@@ -1,110 +0,0 @@
-#
-# @file
-#
-# @brief Makefile of LibBSP for the or1ksim BSP.
-#
-
-ACLOCAL_AMFLAGS = -I ../../../../aclocal
-
-include $(top_srcdir)/../../../../automake/compile.am
-
-include_bspdir = $(includedir)/bsp
-include_libcpudir = $(includedir)/libcpu
-
-dist_project_lib_DATA = bsp_specs
-
-###############################################################################
-# Header #
-###############################################################################
-
-include_bsp_HEADERS =
-include_HEADERS = include/bsp.h
-include_HEADERS += ../../shared/include/tm27.h
-
-nodist_include_bsp_HEADERS = ../../shared/include/bootcard.h
-include_bsp_HEADERS += ../shared/include/linker-symbols.h
-include_bsp_HEADERS += ../../../libbsp/shared/include/mm.h
-include_bsp_HEADERS += ../../shared/include/utility.h
-include_bsp_HEADERS += ../../shared/include/irq-generic.h
-include_bsp_HEADERS += ../../shared/include/irq-info.h
-include_bsp_HEADERS += ../../shared/include/stackalloc.h
-include_bsp_HEADERS += ../../shared/include/uart-output-char.h
-include_bsp_HEADERS += ../shared/include/cache_.h
-include_bsp_HEADERS += include/irq.h
-include_bsp_HEADERS += include/uart.h
-include_bsp_HEADERS += include/or1ksim.h
-
-nodist_include_HEADERS = ../../shared/include/coverhd.h \
- include/bspopts.h
-
-###############################################################################
-# Data #
-###############################################################################
-
-noinst_LIBRARIES = libbspstart.a
-
-libbspstart_a_SOURCES = start/start.S
-
-project_lib_DATA = start.$(OBJEXT)
-
-project_lib_DATA += startup/linkcmds
-project_lib_DATA += ../shared/startup/linkcmds.base
-
-###############################################################################
-# LibBSP #
-###############################################################################
-
-noinst_LIBRARIES += libbsp.a
-
-libbsp_a_SOURCES =
-libbsp_a_CPPFLAGS =
-libbsp_a_LIBADD =
-
-# Startup
-libbsp_a_SOURCES += ../../shared/bspreset.c
-libbsp_a_SOURCES += startup/bspstart.c
-
-# Shared
-libbsp_a_SOURCES += ../../shared/bootcard.c
-libbsp_a_SOURCES += ../../shared/bspclean.c
-libbsp_a_SOURCES += ../../shared/bspgetworkarea.c
-libbsp_a_SOURCES += ../../shared/bsplibc.c
-libbsp_a_SOURCES += ../../shared/bsppost.c
-libbsp_a_SOURCES += ../../shared/bsppredriverhook.c
-libbsp_a_SOURCES += ../../shared/bsppretaskinghook.c
-libbsp_a_SOURCES += ../../shared/gnatinstallhandler.c
-libbsp_a_SOURCES += ../../shared/sbrk.c
-libbsp_a_SOURCES += ../../shared/src/stackalloc.c
-
-# Console
-libbsp_a_SOURCES += ../../shared/console.c
-libbsp_a_SOURCES += ../../shared/console_control.c
-libbsp_a_SOURCES += ../../shared/console_read.c
-libbsp_a_SOURCES += ../../shared/console_select.c
-libbsp_a_SOURCES += ../../shared/console_write.c
-libbsp_a_SOURCES += console/console-config.c
-libbsp_a_SOURCES += console/uart.c
-
-# Timer
-libbsp_a_SOURCES += timer/timer.c
-
-# clock
-libbsp_a_SOURCES += clock/clockdrv.c ../../../shared/clockdrv_shell.h
-
-# IRQ
-libbsp_a_SOURCES += ../../shared/src/irq-default-handler.c
-libbsp_a_SOURCES += ../../shared/src/irq-generic.c
-libbsp_a_SOURCES += ../../shared/src/irq-info.c
-libbsp_a_SOURCES += irq/irq.c
-
-# Cache
-libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/shared/cache.rel
-
-###############################################################################
-# Special Rules #
-###############################################################################
-
-DISTCLEANFILES = include/bspopts.h
-
-include $(srcdir)/preinstall.am
-include $(top_srcdir)/../../../../automake/local.am