summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/no_cpu/no_bsp/timer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/no_cpu/no_bsp/timer/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/no_cpu/no_bsp/timer/Makefile.am b/c/src/lib/libbsp/no_cpu/no_bsp/timer/Makefile.am
index 1923d55d64..e07e5caa10 100644
--- a/c/src/lib/libbsp/no_cpu/no_bsp/timer/Makefile.am
+++ b/c/src/lib/libbsp/no_cpu/no_bsp/timer/Makefile.am
@@ -4,11 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/timer.rel
+PGM = $(ARCH)/timer.rel
-## C source names
C_FILES = timer.c timerisr.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -19,13 +18,15 @@ include $(top_srcdir)/../../../../../../automake/lib.am
# (OPTIONAL) Add local stuff here using +=
#
-$(PGM): ${OBJS}
+$(PGM): $(OBJS)
$(make-rel)
-all-local: ${ARCH} $(PGM)
-
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-EXTRA_DIST = $(C_FILES)
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = timer.c timerisr.c
include $(top_srcdir)/../../../../../../automake/local.am