summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/no_cpu/no_bsp/clock/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/no_cpu/no_bsp/clock/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/c/src/lib/libbsp/no_cpu/no_bsp/clock/Makefile.am b/c/src/lib/libbsp/no_cpu/no_bsp/clock/Makefile.am
index 542d572b47..0b1ebe8a61 100644
--- a/c/src/lib/libbsp/no_cpu/no_bsp/clock/Makefile.am
+++ b/c/src/lib/libbsp/no_cpu/no_bsp/clock/Makefile.am
@@ -4,11 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/clock.rel
+PGM = $(ARCH)/clock.rel
-## C source names
C_FILES = ckinit.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -19,11 +18,15 @@ include $(top_srcdir)/../../../../../../automake/lib.am
# (OPTIONAL) Add local stuff here using +=
#
-$(PGM): ${OBJS}
+$(PGM): $(OBJS)
$(make-rel)
-all-local: ${ARCH} $(PGM)
-
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = ckinit.c
+
include $(top_srcdir)/../../../../../../automake/local.am