summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am b/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
index 0591d294b2..e115697f7e 100644
--- a/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
+++ b/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
@@ -4,10 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/shmsupp.rel
+PGM = $(ARCH)/shmsupp.rel
C_FILES = addrconv.c getcfg.c lock.c mpisr.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -18,14 +18,16 @@ include $(top_srcdir)/../../../../../../automake/lib.am
# (OPTIONAL) Add local stuff here using +=
#
-$(PGM): ${OBJS}
+$(PGM): $(OBJS)
$(make-rel)
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
if HAS_MP
-all-local: ${ARCH} $(OBJS) $(PGM)
+all-local: $(ARCH) $(OBJS) $(PGM)
endif
-# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+.PRECIOUS: $(PGM)
EXTRA_DIST = addrconv.c getcfg.c lock.c mpisr.c