summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/gen68360/network/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/m68k/gen68360/network/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/gen68360/network/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/m68k/gen68360/network/Makefile.am b/c/src/lib/libbsp/m68k/gen68360/network/Makefile.am
new file mode 100644
index 0000000000..06e491fddc
--- /dev/null
+++ b/c/src/lib/libbsp/m68k/gen68360/network/Makefile.am
@@ -0,0 +1,37 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = ${ARCH}/network.rel
+
+C_FILES = network.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+H_FILES = netexterns.h uti596.h
+noinst_HEADERS = $(H_FILES)
+
+network_rel_OBJECTS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+AM_CPPFLAGS += -D__INSIDE_RTEMS_BSD_TCPIP_STACK__
+
+$(PGM): ${network_rel_OBJECTS}
+ $(make-rel)
+
+if HAS_NETWORKING
+all-local: ${ARCH} $(PGM)
+endif
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+EXTRA_DIST = network.c
+
+include $(top_srcdir)/../../../../../../automake/local.am