summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am b/c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am
index 7d63c33815..872aac7ac9 100644
--- a/c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am
@@ -4,7 +4,12 @@
AUTOMAKE_OPTIONS = foreign 1.4
-BSP_PIECES = startup clock console timer
+# We only build the networking device driver if HAS_NETWORKING was defined
+if HAS_NETWORKING
+NETWORKING_DRIVER = network
+endif
+
+BSP_PIECES = startup clock console timer $(NETWORKING_DRIVER)
# bummer; have to use $foreach since % pattern subst rules only replace 1x
OBJS = $(foreach piece, $(BSP_PIECES), $(wildcard ../$(piece)/$(ARCH)/*.o))