summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/lm32/milkymist/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/lm32/milkymist/configure.ac')
-rw-r--r--c/src/lib/libbsp/lm32/milkymist/configure.ac34
1 files changed, 34 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/lm32/milkymist/configure.ac b/c/src/lib/libbsp/lm32/milkymist/configure.ac
new file mode 100644
index 0000000000..62bb7482c7
--- /dev/null
+++ b/c/src/lib/libbsp/lm32/milkymist/configure.ac
@@ -0,0 +1,34 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.60)
+AC_INIT([rtems-c-src-lib-libbsp-lm32-milkymist],
+ [_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define nostdinc foreign 1.10])
+RTEMS_BSP_CONFIGURE
+
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+RTEMS_PROG_CCAS
+
+RTEMS_CHECK_NETWORKING
+AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+
+RTEMS_BSPOPTS_SET([ON_SIMULATOR],[*],[])
+RTEMS_BSPOPTS_HELP([ON_SIMULATOR],
+[If defined, this indicates the BSP is being built to run on the lm32
+ simulator in GDB. This enables fast idle support which speeds up the
+ clock ticks while the idle task is running so time spent in the idle
+ task is minimized. This significantly reduces the wall time required
+ to execute the RTEMS test suites. It also enables a special exit and
+ alternate printk support.])
+
+RTEMS_BSP_CLEANUP_OPTIONS(0,0)
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT