summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/ts_386ex/network/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/i386/ts_386ex/network/Makefile.am17
1 files changed, 8 insertions, 9 deletions
diff --git a/c/src/lib/libbsp/i386/ts_386ex/network/Makefile.am b/c/src/lib/libbsp/i386/ts_386ex/network/Makefile.am
index 2188e6cdf8..b8fef43a99 100644
--- a/c/src/lib/libbsp/i386/ts_386ex/network/Makefile.am
+++ b/c/src/lib/libbsp/i386/ts_386ex/network/Makefile.am
@@ -4,11 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/network.rel
+PGM = $(ARCH)/network.rel
-## C source names
C_FILES = ne2000.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -22,17 +21,17 @@ include $(top_srcdir)/../../../../../../automake/lib.am
AM_CPPFLAGS += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
-DBOOTP_COMPAT
-$(PGM): ${OBJS}
+$(PGM): $(OBJS)
$(make-rel)
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
if HAS_NETWORKING
-all-local: ${ARCH} $(PGM)
-else
-all-local:
+all-local: $(ARCH) $(OBJS) $(PGM)
endif
-# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+.PRECIOUS: $(PGM)
-EXTRA_DIST = $(C_FILES)
+EXTRA_DIST = ne2000.c
include $(top_srcdir)/../../../../../../automake/local.am