summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/timer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/i386/pc386/timer/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/timer/Makefile.am b/c/src/lib/libbsp/i386/pc386/timer/Makefile.am
index 8f377f2007..5e87c956a3 100644
--- a/c/src/lib/libbsp/i386/pc386/timer/Makefile.am
+++ b/c/src/lib/libbsp/i386/pc386/timer/Makefile.am
@@ -4,12 +4,11 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/timer.rel
+PGM = $(ARCH)/timer.rel
-## sources
C_FILES = timer.c
S_FILES = timerisr.S
-timer_rel_OBJECTS = $(C_FILES:%.c=${ARCH}/%.o) $(S_FILES:%.S=${ARCH}/%.o)
+timer_rel_OBJECTS = $(C_FILES:%.c=$(ARCH)/%.o) $(S_FILES:%.S=$(ARCH)/%.o)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../../../../automake/lib.am
@@ -21,11 +20,13 @@ include $(top_srcdir)/../../../../../../automake/lib.am
$(PGM): $(timer_rel_OBJECTS)
$(make-rel)
-all-local: ${ARCH} $(PGM)
-
# the .rel file built here will be put into libbsp.a by
# ../wrapup/Makefile
+all-local: $(ARCH) $(timer_rel_OBJECTS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
EXTRA_DIST = timer.c timerisr.S
include $(top_srcdir)/../../../../../../automake/local.am