summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/configure.ac')
-rw-r--r--c/src/lib/libbsp/i386/pc386/configure.ac38
1 files changed, 23 insertions, 15 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/configure.ac b/c/src/lib/libbsp/i386/pc386/configure.ac
index f8855eece9..469d5f59e9 100644
--- a/c/src/lib/libbsp/i386/pc386/configure.ac
+++ b/c/src/lib/libbsp/i386/pc386/configure.ac
@@ -99,21 +99,8 @@ RTEMS_BSPOPTS_HELP([CLOCK_DRIVER_USE_8254],
- you do not mind adding roughly 5 microseconds to each context switch.
])
-RTEMS_BSPOPTS_SET([USE_CIRRUS_GD5446],[*],[0])
-RTEMS_BSPOPTS_HELP([USE_CIRRUS_GD5446],
-[If defined, enable use of the Cirrus GD5446 controller rather than the very basic
- VGA driver for frame buffer support.
-
- NOTE: This has only been tested on Qemu.])
-AM_CONDITIONAL(USE_CIRRUS_GD5446,test "$USE_CIRRUS_GD5446" = "1")
-
-RTEMS_BSPOPTS_SET([USE_VBE_RM],[*],[0])
-RTEMS_BSPOPTS_HELP([USE_VBE_RM],
-[If defined, enables use of the Vesa Bios Extensions - real mode interface,
- which enables graphical mode and introduce it upon bootup.])
-AM_CONDITIONAL(USE_VBE_RM,test "$USE_VBE_RM" = "1")
-
-if test "${USE_VBE_RM}" = "1" ; then
+if test "${USE_CIRRUS_GD5446}" != "1" -a "${USE_VGA}" != "1"; then
+ USE_VBE_RM=1;
if test -z "${NUM_APP_DRV_GDT_DESCRIPTORS}"; then
NUM_APP_DRV_GDT_DESCRIPTORS=2 ;
else
@@ -125,6 +112,27 @@ RTEMS_BSPOPTS_HELP([NUM_APP_DRV_GDT_DESCRIPTORS],
[Defines how many descriptors in GDT may be allocated for application or
driver usage.])
+RTEMS_BSPOPTS_SET([USE_CIRRUS_GD5446],[*],[0])
+RTEMS_BSPOPTS_HELP([USE_CIRRUS_GD5446],
+[If defined, enables use of the Cirrus GD5446 controller rather than the
+ controller utilizing Vesa Bios Extensions - real mode interface.
+
+ NOTE: This has only been tested on Qemu.])
+AM_CONDITIONAL(USE_CIRRUS_GD5446,test "$USE_CIRRUS_GD5446" = "1")
+
+RTEMS_BSPOPTS_SET([USE_VGA],[*],[0])
+RTEMS_BSPOPTS_HELP([USE_VGA],
+[If defined, enables use of the very basic VGA driver for framebuffer support
+ rather than the controller utilizing Vesa Bios Extensions - real mode
+ interface.])
+AM_CONDITIONAL(USE_VGA,test "$USE_VGA" = "1")
+
+RTEMS_BSPOPTS_SET([USE_VBE_RM],[*],[0])
+RTEMS_BSPOPTS_HELP([USE_VBE_RM],
+[Defined by default. Enables use of the Vesa Bios Extensions - real mode
+ interface, which enables graphical mode and introduce it upon bootup.])
+AM_CONDITIONAL(USE_VBE_RM,test "$USE_VBE_RM" = "1")
+
if test X${CLOCK_DRIVER_USE_TSC} = X1 -a X${CLOCK_DRIVER_USE_8254} = X1 ; then
AC_MSG_ERROR([pc386 both TSC and 8254 specified for clock driver])
fi