summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i386/pc386/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/Makefile.am b/c/src/lib/libbsp/i386/pc386/Makefile.am
new file mode 100644
index 0000000000..66d4dd9e23
--- /dev/null
+++ b/c/src/lib/libbsp/i386/pc386/Makefile.am
@@ -0,0 +1,23 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
+if HAS_NETWORKING
+# We only build the Network library if HAS_NETWORKING was defined
+# dec21140 is supported via libchip
+NETWORK = ne2000 wd8003 3c509
+endif
+
+# wrapup is the one that actually builds and installs the library
+# from the individual .rel files built in other directories
+SUBDIRS = . include tools start startup clock console timer $(NETWORK) wrapup
+
+include $(top_srcdir)/../../bsp.am
+
+EXTRA_DIST = HOWTO README.dec21140 STATUS bsp_specs times_i486dx times_p5
+
+include $(top_srcdir)/../../../../../../automake/subdirs.am
+include $(top_srcdir)/../../../../../../automake/local.am