summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am b/c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am
new file mode 100644
index 0000000000..da6da12e41
--- /dev/null
+++ b/c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am
@@ -0,0 +1,34 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = bsp.h ../../../shared/include/coverhd.h
+
+RTEMS_H_FILES = ttydrv.h
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/bsp.h: bsp.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/coverhd.h: ../../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/rtems/ttydrv.h: ttydrv.h
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/bsp.h \
+ $(PROJECT_INCLUDE)/coverhd.h $(PROJECT_INCLUDE)/rtems \
+ $(PROJECT_INCLUDE)/rtems/ttydrv.h
+
+all-local: $(TMPINSTALL_FILES)
+
+EXTRA_DIST = bsp.h ttydrv.h
+
+include $(top_srcdir)/../../../../../../automake/local.am