summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/lpc24xx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/arm/lpc24xx/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/arm/lpc24xx/Makefile.am b/c/src/lib/libbsp/arm/lpc24xx/Makefile.am
index 4122620796..86f945ad20 100644
--- a/c/src/lib/libbsp/arm/lpc24xx/Makefile.am
+++ b/c/src/lib/libbsp/arm/lpc24xx/Makefile.am
@@ -10,7 +10,6 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../bsp.am
include_bspdir = $(includedir)/bsp
@@ -40,8 +39,8 @@ include_bsp_HEADERS = ../../shared/include/utility.h \
# Data #
###############################################################################
-EXTRA_DIST = ../shared/start/start.S
-
+noinst_LIBRARIES = libbspstart.a
+libbspstart_a_SOURCES = ../shared/start/start.S
project_lib_DATA = start.$(OBJEXT)
dist_project_lib_DATA += ../shared/startup/linkcmds.base startup/linkcmds
@@ -49,7 +48,7 @@ dist_project_lib_DATA += ../shared/startup/linkcmds.base startup/linkcmds
###############################################################################
# LibBSP #
###############################################################################
-noinst_LIBRARIES = libbsp.a
+noinst_LIBRARIES += libbsp.a
libbsp_a_SOURCES =
# shared