summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/Makefile.am')
-rw-r--r--c/src/lib/libbsp/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/Makefile.am b/c/src/lib/libbsp/Makefile.am
new file mode 100644
index 0000000000..4bc5cdb4e2
--- /dev/null
+++ b/c/src/lib/libbsp/Makefile.am
@@ -0,0 +1,19 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
+# If we are building a "real" BSP, then we need to descend into the
+# appropriate CPU specific directory. The bare BSP is a special
+# case which can be built for any CPU and it resides at the same
+# level as the CPUs. If we are building the bare BSP, then descend
+# into that directory.
+
+SUBDIRS += shmdr @RTEMS_LIBBSP_CPU_SUBDIR@
+
+EXTRA_DIST = MERGE.PROCEDURE bsp.am
+
+include $(top_srcdir)/../../../../automake/subdirs.am
+include $(top_srcdir)/../../../../automake/local.am