summaryrefslogtreecommitdiffstats
path: root/c/src/lib/include/sys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--c/src/lib/include/sys/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/c/src/lib/include/sys/Makefile.am b/c/src/lib/include/sys/Makefile.am
new file mode 100644
index 0000000000..a43474404f
--- /dev/null
+++ b/c/src/lib/include/sys/Makefile.am
@@ -0,0 +1,34 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+if HAS_NETWORKING
+else
+NETWORKING_H_PIECES += ioctl.h
+endif
+
+if UNIX
+else
+NEWLIB_H_PIECES += termios.h
+endif
+
+H_PIECES += utime.h $(NEWLIB_H_PIECES) $(NETWORKING_H_PIECES)
+
+noinst_HEADERS = $(H_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE)/sys \
+$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/sys/%)
+
+$(PROJECT_INCLUDE)/sys:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/sys/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../automake/local.am