summaryrefslogtreecommitdiffstats
path: root/c/src/lib/include/sys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/include/sys/Makefile.am')
-rw-r--r--c/src/lib/include/sys/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/c/src/lib/include/sys/Makefile.am b/c/src/lib/include/sys/Makefile.am
index 32068894e5..aa8c375690 100644
--- a/c/src/lib/include/sys/Makefile.am
+++ b/c/src/lib/include/sys/Makefile.am
@@ -18,17 +18,14 @@ H_FILES = utime.h $(NEWLIB_H_FILES) $(NETWORKING_H_FILES)
noinst_HEADERS = utime.h termios.h ioctl.h
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/sys \
-$(H_FILES:%=$(PROJECT_INCLUDE)/sys/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/sys/%)
$(PROJECT_INCLUDE)/sys:
@$(mkinstalldirs) $@
$(PROJECT_INCLUDE)/sys/%.h: %.h
$(INSTALL_DATA) $< $@
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am