summaryrefslogtreecommitdiffstats
path: root/c/src/lib/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/include/Makefile.am')
-rw-r--r--c/src/lib/include/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/c/src/lib/include/Makefile.am b/c/src/lib/include/Makefile.am
new file mode 100644
index 0000000000..1a3640a7ed
--- /dev/null
+++ b/c/src/lib/include/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_PIECES = chain.h console.h clockdrv.h iosupp.h ringbuf.h spurious.h \
+ timerdrv.h vmeintr.h
+
+noinst_HEADERS = $(H_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE) \
+$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+$(PROJECT_INCLUDE):
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+SUBDIRS = sys motorola zilog rpc rdbg
+
+include $(top_srcdir)/../../../automake/subdirs.am
+include $(top_srcdir)/../../../automake/local.am