summaryrefslogtreecommitdiffstats
path: root/c/src/lib/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/include/Makefile.am')
-rw-r--r--c/src/lib/include/Makefile.am79
1 files changed, 0 insertions, 79 deletions
diff --git a/c/src/lib/include/Makefile.am b/c/src/lib/include/Makefile.am
deleted file mode 100644
index d334846f7e..0000000000
--- a/c/src/lib/include/Makefile.am
+++ /dev/null
@@ -1,79 +0,0 @@
-##
-## $Id$
-##
-
-
-include_HEADERS = chain.h console.h clockdrv.h iosupp.h ringbuf.h rtc.h \
- spurious.h timerdrv.h vmeintr.h
-
-LIBC_HFILES = stdint.h inttypes.h
-include_HEADERS += $(LIBC_HFILES)
-
-PREINSTALL_FILES = $(PROJECT_INCLUDE) \
- $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
-$(PROJECT_INCLUDE):
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/motorola:
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/rtems:
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/sys:
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/zilog:
- @$(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-## motorola
-
-include_motoroladir = $(includedir)/motorola
-
-include_motorola_HEADERS = motorola/mc68230.h motorola/mc68681.h
-
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/motorola \
- $(include_motorola_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
-## rtems
-include_rtemsdir = $(includedir)/rtems
-
-include_rtems_HEADERS = \
- rtems/assoc.h rtems/error.h rtems/libcsupport.h rtems/libio.h rtems/libio_.h \
- rtems/termiostypes.h
-
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
- $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
-## sys
-
-include_sysdir = $(includedir)/sys
-
-NETWORKING_H_FILES = sys/ioctl.h sys/sockio.h sys/filio.h
-
-if NEWLIB
-NEWLIB_H_FILES = sys/termios.h sys/cdefs.h
-endif
-
-include_sys_HEADERS = \
-sys/ioccom.h \
-sys/ttycom.h \
-sys/utime.h \
-$(NEWLIB_H_FILES) $(NETWORKING_H_FILES)
-
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys \
- $(include_sys_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
-## zilog
-
-include_zilogdir = $(includedir)/zilog
-
-include_zilog_HEADERS = zilog/z8036.h zilog/z8530.h zilog/z8536.h
-
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/zilog \
- $(include_zilog_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
-## General stuff
-all-local: $(PREINSTALL_FILES)
-
-include $(top_srcdir)/../../../automake/local.am